aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-07-11 14:08:35 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:02:01 +0200
commit764c5c07165848a7821cf835925331dc3fa27384 (patch)
treec631fd8b81c3643a96ab066845ab2fce1b16d747
parentca5a74e816522dbac3f06ac6d89f2fc6f418fe43 (diff)
downloadmeta-openembedded-764c5c07165848a7821cf835925331dc3fa27384.tar.gz
libnet-libidn-perl: add recipe
Signed-off-by: Roy Li <rongqing.li@windriver.com> Acked-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-libidn-perl-0.12/libidn-wr-cross-compile.patch49
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-libidn-perl_0.12.bb34
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-libidn-perl-0.12/libidn-wr-cross-compile.patch b/meta-perl/recipes-perl/libnet/libnet-libidn-perl-0.12/libidn-wr-cross-compile.patch
new file mode 100644
index 0000000000..679caa36a1
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-libidn-perl-0.12/libidn-wr-cross-compile.patch
@@ -0,0 +1,49 @@
+perl-Net-LibIDN: cross-compile
+
+Upstream-Status: Pending
+
+Add support for cross-compile allowing the compiler binary to be
+specified into the perl Makefile instead of using the default 'gcc'.
+
+Signed-off-by: Greg Moffatt <greg.moffatt@windriver.com>
+---
+
+--- perl-Net-LibIDN-0.12.orig/Makefile.PL 2009-02-26 07:09:45.000000000 -0500
++++ perl-Net-LibIDN-0.12/Makefile.PL 2010-10-19 09:34:22.811173965 -0400
+@@ -9,6 +9,7 @@
+ my $options;
+ my $testno=1;
+ my %MakeParams = InitMakeParams();
++my $compiler;
+
+ WriteMakefile(%MakeParams);
+
+@@ -44,7 +45,8 @@
+ (
+ "with-libidn=s" => \$libdir,
+ "with-libidn-inc=s" => \$incdir,
+- "disable-tld" => \$disable_tld
++ "disable-tld" => \$disable_tld,
++ "compiler=s" => \$compiler
+ );
+
+ if ($libdir)
+@@ -165,12 +167,17 @@
+ return 0;
+ }
+
+- foreach my $cc (qw/cc gcc/)
++ foreach my $cc ($compiler, qw/cc gcc/)
+ {
+ unlink($test);
+ system "$cc $cflags -o $test $test.c $ldflags";
+ next if ($? >> 8);
+
++ if ($compiler == $cc)
++ {
++ return 1;
++ }
++
+ if (open(FILE, "./$test|"))
+ {
+ my $match;
diff --git a/meta-perl/recipes-perl/libnet/libnet-libidn-perl_0.12.bb b/meta-perl/recipes-perl/libnet/libnet-libidn-perl_0.12.bb
new file mode 100644
index 0000000000..42b213dbdd
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-libidn-perl_0.12.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Net::LibIDN - Perl bindings for GNU Libidn"
+DESCRIPTION = "\
+Provides bindings for GNU Libidn, a C library for handling Internationalized \
+Domain Names according to IDNA (RFC 3490), in a way very much inspired by \
+Turbo Fredriksson's PHP-IDN. \
+"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPLv1+"
+HOMEPAGE = "http://search.cpan.org/dist/Net-LibIDN/"
+DEPENDS += "libidn"
+# We must need eglibc-gconvs to enable charset related functions,
+# such as Net::LibIDN::idn_to_ascii().
+RDEPENDS_${PN} += "eglibc-gconvs"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TH/THOR/Net-LibIDN-${PV}.tar.gz"
+SRC_URI[md5sum] = "c3e4de2065009d67bcb1df0afb473e12"
+SRC_URI[sha256sum] = "2f8acc9442b3866ec7dc63cd449fc693ae3e930d5d3e5e9430fbb6f393bdbb17"
+
+SRC_URI += "file://libidn-wr-cross-compile.patch"
+
+LIC_FILES_CHKSUM = "file://README;beginline=42;endline=92;md5=3374ea0369ca3ead6047520477a43147"
+
+S = "${WORKDIR}/Net-LibIDN-${PV}"
+
+EXTRA_CPANFLAGS = "--with-libidn=${STAGING_LIBDIR} --with-libidn-inc=${STAGING_INCDIR} --compiler='${CC}'"
+EXTRA_CPANFLAGS += "--disable-tld"
+
+inherit cpan
+
+FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Net/LibIDN/.debug/"
+
+do_configure_prepend() {
+ rm -rf ${S}/.pc/
+}