aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-15 18:42:31 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-16 01:12:05 -0700
commit6b77b1a957304717aef89a22588bd14221cc5339 (patch)
treef5294b4a64533ca2c6c906c19f21707486245180
parent010c2f388095c1615b99d9f38a26bbd0c9e77b39 (diff)
downloadmeta-openembedded-6b77b1a957304717aef89a22588bd14221cc5339.tar.gz
libnice: Drop support for gstreamer-0.10
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.1.14.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/farsight/libnice_0.1.14.bb b/meta-oe/recipes-support/farsight/libnice_0.1.14.bb
index 775257f93c..967beeba42 100644
--- a/meta-oe/recipes-support/farsight/libnice_0.1.14.bb
+++ b/meta-oe/recipes-support/farsight/libnice_0.1.14.bb
@@ -15,15 +15,16 @@ DEPENDS = "glib-2.0 gnutls"
PACKAGECONFIG ??= "gstreamer1.0"
PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
-PACKAGECONFIG[gstreamer0.10] = "--with-gstreamer-0.10,--without-gstreamer-0.10,gstreamer gst-plugins-base"
PACKAGECONFIG[gstreamer1.0] = "--with-gstreamer,--without-gstreamer,gstreamer1.0 gstreamer1.0-plugins-base"
inherit autotools pkgconfig gtk-doc gobject-introspection
-FILES_${PN} += "${libdir}/gstreamer-0.10/*.so ${libdir}/gstreamer-1.0/*.so"
-FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-1.0/*.la"
-FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a ${libdir}/gstreamer-1.0/*.a"
-FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug ${libdir}/gstreamer-1.0/.debug"
+EXTRA_OECONF += "--without-gstreamer-0.10"
+
+FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
+FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
+FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
do_configure_prepend() {
mkdir ${S}/m4 || true