aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Pellegrin <fede@evolware.org>2022-10-06 14:17:21 +0200
committerKhem Raj <raj.khem@gmail.com>2022-10-06 07:20:50 -0700
commit22682fdfb747e72ec1400a9df2ae0324dbca6d16 (patch)
tree3b59a6fcc02f28e060fbe1b2d7a9c637226d94a2
parent6b7cf95e75cbfc08cf1f6eddc7ce3f6a0a39edcf (diff)
downloadmeta-openembedded-22682fdfb747e72ec1400a9df2ae0324dbca6d16.tar.gz
chrony: add pkgconfig class as pkg-config is explicitly searched for
The configure script present in chrony will explicitly look for pkg-config and without the pkgconfig class it will fail: Checking for pkg-config : No This then affects the possibility (via image features or bbappend) to use features based on nettle/gnutls/nss which strictly require pkgconfig to be present and working. Signed-off-by: Federico Pellegrin <fede@evolware.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/chrony/chrony_4.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony_4.3.bb b/meta-networking/recipes-support/chrony/chrony_4.3.bb
index 083d2cbc00..6617164e3d 100644
--- a/meta-networking/recipes-support/chrony/chrony_4.3.bb
+++ b/meta-networking/recipes-support/chrony/chrony_4.3.bb
@@ -45,7 +45,7 @@ DEPENDS = "pps-tools"
# Note: Despite being built via './configure; make; make install',
# chrony does not use GNU Autotools.
-inherit update-rc.d systemd
+inherit update-rc.d systemd pkgconfig
# Add chronyd user if privdrop packageconfig is selected
inherit ${@bb.utils.contains('PACKAGECONFIG', 'privdrop', 'useradd', '', d)}