aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Belski <anbelski@microsoft.com>2019-07-22 00:53:30 +0000
committerKhem Raj <raj.khem@gmail.com>2019-07-22 09:31:46 -0700
commit1636db7e6a129466f44fc565319d684696e4914c (patch)
tree502cd97d27a03203983fe464eae4a4ee648c8893
parent74ca25227b0aad189339d841f36a7117ff4b7a64 (diff)
downloadmeta-openembedded-1636db7e6a129466f44fc565319d684696e4914c.tar.gz
gperftools: separate off libtcmalloc-minimal
From: Anatol Belski <anbelski@microsoft.com> The libctmalloc-minimal is what is useful for C++ apps if only the improved allocator is needed. The gperftools package stays otherwise fully backward compatible as it's going to depend on libtcmalloc-minimal. The libtcmalloc-minimal can be installed separately, which allows for more flexibility and for cleaner image contents. The discussion on the patch https://patchwork.openembedded.org/patch/163234/ has shown, that a separate package for other libs might have less sense in this case, so it's not done. The patch 163234 can be abandoned in favor of this for now. Signed-off-by: Anatol Belski <anbelski@microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.7.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
index c8b91278da..c48a98183d 100644
--- a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
@@ -28,3 +28,11 @@ COMPATIBLE_HOST_mipsarch_libc-glibc = "null"
ARM_INSTRUCTION_SET_armv5 = "arm"
ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
+# Ensure static libs are always enabled, as they seem to be not produced by
+# default at least on ARM.
+EXTRA_OECONF_append += " --enable-static"
+
+PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
+FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
+RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"
+