aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-03-05 23:04:51 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:01:16 -0700
commit154d1cc86359550046ef99ef8686920a91663dd2 (patch)
treed50ed1a6ae011d2c593ae7f5d04a6e1e17244505
parentd93df171bec4b4d9bb4fdafb62f3ffd0d9d4b7f2 (diff)
downloadmeta-openembedded-154d1cc86359550046ef99ef8686920a91663dd2.tar.gz
nodejs: add extra RDEPENDS for building
If you want to perform an "npm install" and a module needs to be compiled, these additional packages need to be on the target otherwise the compile might fail with one or more of the following error messages: ImportError: No module named compiler.ast ImportError: No module named filecmp ImportError: No module named multiprocessing Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_8.9.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_8.9.4.bb b/meta-oe/recipes-devtools/nodejs/nodejs_8.9.4.bb
index afd2d96d85..8930cd9022 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_8.9.4.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_8.9.4.bb
@@ -80,7 +80,8 @@ do_install_append_class-target() {
PACKAGES =+ "${PN}-npm"
FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx"
-RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
+RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils \
+ python-compiler python-misc python-multiprocessing"
PACKAGES =+ "${PN}-systemtap"
FILES_${PN}-systemtap = "${datadir}/systemtap"