aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-03 08:59:00 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit09a2eb4701348939d96d403544e082d5a0f9c05e (patch)
treeef5dcd6ef4afa3b0d294b7ebff66fd6799832145
parentcca388f870753b88cfa0e668864aa0a843e4484a (diff)
downloadmeta-openembedded-09a2eb4701348939d96d403544e082d5a0f9c05e.tar.gz
openlmi-tools: Fix setup.py clean during build
setuptools bbclass now runs clean target before configure therefore create the setup.py before main configure task secondly, all action happens inside cli subdir so mark it default S Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
index 05dc854fca..419b3ee6e8 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -2,7 +2,7 @@ SUMMARY = "Set of CLI tools for Openlmi providers"
DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
HOMEPAGE = "http://www.openlmi.org/"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
SECTION = "System/Management"
inherit setuptools
@@ -14,13 +14,11 @@ SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
-do_compile_prepend() {
- cd cli
+S = "${WORKDIR}/${BP}/cli"
+
+do_configure_prepend() {
sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py
}
-do_install_prepend() {
- cd cli
-}
python() {
if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():