aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:54 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-11 13:26:25 -0800
commit0f1dff98a4d4a5c863ca5f4b1fd6c52c2efbe709 (patch)
tree0a9a45a7d3b1473bdcf2149bd70a868d8587dbf0
parent9132eef66b8f82ef1005a9e76e750d18a6f431f7 (diff)
downloadmeta-openembedded-0f1dff98a4d4a5c863ca5f4b1fd6c52c2efbe709.tar.gz
python-twisted: clean-up the dependencies
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-twisted_17.9.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 4bd4788674..0dd584f9fe 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -41,16 +41,16 @@ PACKAGES =+ "\
RDEPENDS_${PN} = "\
${PN}-bin \
+ ${PN}-core \
${PN}-conch \
${PN}-mail \
${PN}-names \
- ${PN}-news \
${PN}-runner \
${PN}-web \
${PN}-words \
"
-RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib"
+RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat"
RDEPENDS_${PN}-test = "${PN}"
RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
diff --git a/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
index 3b4511077f..2be1709d04 100644
--- a/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
@@ -1,4 +1,4 @@
inherit pypi setuptools
require python-twisted.inc
-RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib"
+RDEPENDS_${PN}-core += "${PYTHON_PN}-contextlib"
diff --git a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
index 98016cca39..d7533d8e70 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
@@ -1,7 +1,7 @@
inherit pypi setuptools3
require python-twisted.inc
-RDEPENDS_${PN}-core = "python3-core python3-zopeinterface python3-lang"
+RDEPENDS_${PN}-core += "python3-lang"
FILES_${PN}-core_append += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \