aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-10-02 09:06:54 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:29 +0000
commite222c07ae9b38f77095c76c326f16dc17dcc73c9 (patch)
tree978cab442bddaa612aef3528633eb62024250831
parent70690999be78ef1e012ab2bbe2e91485a8a6a1e5 (diff)
downloadmeta-openembedded-e222c07ae9b38f77095c76c326f16dc17dcc73c9.tar.gz
python-m2crypto: Upgrade to 0.26.4
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch24
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb (renamed from meta-python/recipes-devtools/python/python-m2crypto_0.26.0.bb)6
2 files changed, 27 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch b/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch
new file mode 100644
index 0000000000..2d738cc94e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch
@@ -0,0 +1,24 @@
+Imported from Fedora
+
+--- M2Crypto/SWIG/_m2crypto.i 2017-09-26 11:26:33.000000000 +0200
++++ M2Crypto-0.26.4/SWIG/_m2crypto.i 2017-09-26 21:04:14.080330741 +0200
+@@ -7,6 +7,7 @@
+ * Copyright (c) 2009-2010 Heikki Toivonen. All rights reserved.
+ *
+ */
++%import "gcc_macros.h"
+
+ %module(threads=1) m2crypto
+ /* We really don't need threadblock (PyGILState_Ensure() etc.) anywhere.
+@@ -15,11 +16,6 @@
+ %nothreadblock;
+ %nothreadallow;
+
+-#if SWIG_VERSION >= 0x030000
+-#define __WCHAR_MAX__ __WCHAR_MAX
+-#define __WCHAR_MIN__ __WCHAR_MIN
+-#endif
+-
+ %{
+ #if __GNUC__ < 5
+ #pragma GCC diagnostic ignored "-Wunused-label"
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.26.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb
index 4b4fbbb7c2..272c76ca17 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.26.0.bb
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.26.4.bb
@@ -6,9 +6,10 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
file://cross-compile-platform.patch \
+ file://m2crypto-0.26.4-gcc_macros.patch \
"
-SRC_URI[md5sum] = "9f02f0b88fbe225cc6ea8680945cafa0"
-SRC_URI[sha256sum] = "05d94fd9b2dae2fb8e072819a795f0e05d3611b09ea185f68e1630530ec09ae8"
+SRC_URI[md5sum] = "5c74c25ba8b45122318a165a3a2059ad"
+SRC_URI[sha256sum] = "5cae7acc0b34821f8c0ddf6665e482893fe1f198ad6379e61ffa9d8e65f5c199"
PYPI_PACKAGE = "M2Crypto"
inherit pypi setuptools siteinfo
@@ -46,5 +47,4 @@ do_compile_prepend() {
fi
}
-
BBCLASSEXTEND = "native"