aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-07 23:39:29 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:43 -0700
commit807b102f9f2faa3e23b79e5b6219c01bf6990e11 (patch)
tree7f28e5a9011c8b2a23877cc24d767dc2ff59c7d8
parent99412515cd49c34b4224b5c074cb69513377d372 (diff)
downloadmeta-openembedded-807b102f9f2faa3e23b79e5b6219c01bf6990e11.tar.gz
openipmi: refresh patches
WARNING: openipmi-2.0.24-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch include_sys_types.patch patching file ui/ui.c Hunk #1 succeeded at 42 with fuzz 1. Now at patch include_sys_types.patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/openipmi/files/fix-symlink-install-error-in-cmdlang.patch10
-rw-r--r--meta-networking/recipes-support/openipmi/files/include_sys_types.patch8
2 files changed, 9 insertions, 9 deletions
diff --git a/meta-networking/recipes-support/openipmi/files/fix-symlink-install-error-in-cmdlang.patch b/meta-networking/recipes-support/openipmi/files/fix-symlink-install-error-in-cmdlang.patch
index 9a568b2b22..449142fcfa 100644
--- a/meta-networking/recipes-support/openipmi/files/fix-symlink-install-error-in-cmdlang.patch
+++ b/meta-networking/recipes-support/openipmi/files/fix-symlink-install-error-in-cmdlang.patch
@@ -8,11 +8,11 @@ Date: Thu Jun 7 16:00:13 2012 -0400
Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
-diff --git a/cmdlang/Makefile.am b/cmdlang/Makefile.am
-index 92d6e83..f6039f9 100644
---- a/cmdlang/Makefile.am
-+++ b/cmdlang/Makefile.am
-@@ -36,6 +36,7 @@ CLEANFILES = libOpenIPMIcmdlang.map
+Index: OpenIPMI-2.0.24/cmdlang/Makefile.am
+===================================================================
+--- OpenIPMI-2.0.24.orig/cmdlang/Makefile.am
++++ OpenIPMI-2.0.24/cmdlang/Makefile.am
+@@ -35,6 +35,7 @@ openipmish_LDADD = libOpenIPMIcmdlang.l
# compatability.
install-data-local:
rm -f $(DESTDIR)$(bindir)/ipmish
diff --git a/meta-networking/recipes-support/openipmi/files/include_sys_types.patch b/meta-networking/recipes-support/openipmi/files/include_sys_types.patch
index 58ec5d8834..082511a67b 100644
--- a/meta-networking/recipes-support/openipmi/files/include_sys_types.patch
+++ b/meta-networking/recipes-support/openipmi/files/include_sys_types.patch
@@ -3,10 +3,10 @@ include sys/types.h for u_int32_t
ui.c:340:5: error: unknown type name 'u_int32_t'; did you mean 'uint32_t'?
u_int32_t addr;
^~~~~~~~~
-Index: OpenIPMI-2.0.22/ui/ui.c
+Index: OpenIPMI-2.0.24/ui/ui.c
===================================================================
---- OpenIPMI-2.0.22.orig/ui/ui.c
-+++ OpenIPMI-2.0.22/ui/ui.c
+--- OpenIPMI-2.0.24.orig/ui/ui.c
++++ OpenIPMI-2.0.24/ui/ui.c
@@ -42,6 +42,7 @@
#include <fcntl.h>
#include <time.h>
@@ -14,4 +14,4 @@ Index: OpenIPMI-2.0.22/ui/ui.c
+#include <sys/types.h>
#include <ctype.h>
- #include <OpenIPMI/selector.h>
+ #include <OpenIPMI/ipmi_err.h>