aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Menschel <menschel-d@posteo.de>2018-07-21 01:29:37 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-21 00:26:49 -0700
commit5b85349b05aedf4dee3f9fa7bba8303208ffd95a (patch)
treea27cbc65e7ea56041f8f3df02a76ce77f4922663
parentd75280b749bf70c6dec723e6f99688521a1a6a88 (diff)
downloadmeta-openembedded-5b85349b05aedf4dee3f9fa7bba8303208ffd95a.tar.gz
python-semver: add new recipe
This small python module provides a way to manage and compare version strings which adhere to the Semantic Versioning specification [1]. [1] https://semver.org Signed-off-by: Dennis Menschel <menschel-d@posteo.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-semver.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-semver_2.8.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-semver_2.8.1.bb2
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-semver.inc b/meta-python/recipes-devtools/python/python-semver.inc
new file mode 100644
index 0000000000..3c95c06eaf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-semver.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Python module for Semantic Versioning"
+HOMEPAGE = "https://github.com/k-bx/python-semver"
+BUGTRACKER = "https://github.com/k-bx/python-semver/issues"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+SRC_URI[md5sum] = "dc579ba9d0bb2137bad5324d4bdb7e40"
+SRC_URI[sha256sum] = "5b09010a66d9a3837211bb7ae5a20d10ba88f8cb49e92cb139a69ef90d5060d8"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-semver_2.8.1.bb b/meta-python/recipes-devtools/python/python-semver_2.8.1.bb
new file mode 100644
index 0000000000..0572feb31b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-semver_2.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-semver.inc
diff --git a/meta-python/recipes-devtools/python/python3-semver_2.8.1.bb b/meta-python/recipes-devtools/python/python3-semver_2.8.1.bb
new file mode 100644
index 0000000000..77925ae2b1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-semver_2.8.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-semver.inc