aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-11-26 00:42:04 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 08:59:25 +0100
commitad5ab7a9bf671b86e9e18e89cc9439b7b7c4b17b (patch)
tree0dd8dd1e3b496492be1455dfc3f5b6b0adf196b5
parent44c2fd2b393408ae22701071006918b1ea01f3d5 (diff)
downloadmeta-openembedded-ad5ab7a9bf671b86e9e18e89cc9439b7b7c4b17b.tar.gz
meta-ruby: Add LAYERVERSION and LAYERDEPENDS
According to README, it depends on oe-core and openembedded-layer Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-ruby/conf/layer.conf6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-ruby/conf/layer.conf b/meta-ruby/conf/layer.conf
index 6c2369f2c4..b526a5d394 100644
--- a/meta-ruby/conf/layer.conf
+++ b/meta-ruby/conf/layer.conf
@@ -7,3 +7,9 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "ruby-layer"
BBFILE_PATTERN_ruby-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_ruby-layer = "7"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_ruby-layer = "1"
+
+LAYERDEPENDS_ruby-layer = "core openembedded-layer"