aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
Commit message (Collapse)AuthorAgeFilesLines
* packagegroup-meta-oe: espeak-data is goneHEADmasterKhem Raj5 days1-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* espeak: Generate phondata based on endianness of targerKhem Raj6 days5-61/+71
| | | | | | | | | | Use qemu usermode to generate it, so we are always in correct endian-ness espeak-data is no longer needed now, since sole purpose of it was to provide the data for bigendian systems Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ftgl: Fix build errors with clangKhem Raj6 days2-0/+39
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* wifi-test-suite: Fix build with LTOKhem Raj6 days2-0/+39
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ftgl: initial add 2.1.3-rc5Andreas Müller8 days3-0/+100
| | | | | | | | Have this in meta-qt5-extra for a while but now it is required by upcoming chromium-bsi (meta-games). So move a layer 'up'. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vncx11: Fix dev package do_rootfs failureAlistair Francis8 days1-0/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | When building the dev package I see these errors: Collected errors: * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbproto.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfb.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbregion.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbconfig.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/keysym.h But that file is already provided by package * libvncserver-dev * check_data_file_clashes: Package x11vnc-dev wants to install file /home/alistair/oe-master/build/tmp-glibc/wor k/sopine_a64-oe-linux/core-image-weston/1.0-r0/rootfs/usr/include/rfb/rfbclient.h But that file is already provided by package * libvncserver-dev as both libvncserver and x11vnx try to install the same files let's just remove them from x11vnc. Signed-off-by: Alistair Francis <alistair@alistair23.me> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rapidjson: fix cmake artifacts installation for non-default BASELIB caseRuslan Bilovol9 days2-2/+39
| | | | | | | | | | | | | | | | | | | | | If BASELIB is set to non-default value (like lib64), next 'installed but not shipped' issue happens: /usr/lib /usr/lib/cmake /usr/lib/pkgconfig /usr/lib/cmake/RapidJSON /usr/lib/cmake/RapidJSON/RapidJSONConfigVersion.cmake /usr/lib/cmake/RapidJSON/RapidJSONConfig.cmake /usr/lib/pkgconfig/RapidJSON.pc This is because rapidjson has library installation dir set to 'lib' by default and hardcoded in another place. Fix this by next changes: - set appropriate LIB_INSTALL_DIR - fix hardcoded 'lib' in CMAKECONFIG_INSTALL_DIR case Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* glmark2: update to current gitRoss Burton10 days4-105/+3
| | | | | | | | | | | | | Remove two patches merged upstream. The other patch isn't required so can be deleted. Remove explicit --std=c++11 as the wscript adds --std=c++14 now. Change PV to contain the full date just in case we want to update more than once a month. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ltrace: Fix build with clangKhem Raj11 days2-0/+34
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Fix build with clangKhem Raj11 days2-0/+29
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Upgrade to 4.0.6Khem Raj11 days3-56/+562
| | | | | | Change License to SSPL version 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Update to 5.18 branch ( 5.18.2 )Khem Raj11 days1-3/+3
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* graphviz: Fix cross-build failures with clangKhem Raj11 days1-4/+14
| | | | | | | | | | | | | | | | | | It is detecting cross compile badness for -lexpat since the check finds it on build host, so aide the build ssytem to find it in staging sysroot Disable internal ltdl, use libtool provided one Define defines to indicate that platform has ssize_t and long_double Disable java,r,c-sharp, as it is unused Arrange source URIs before checksums gtk-doc is not needed, morever it ends up in unknown configure options Signed-off-by: Khem Raj <raj.khem@gmail.com>
* catch2: Upgrade to 2.6.0Khem Raj11 days2-41/+2
| | | | | | Drop backported patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
* breakpad: Drop SRCPV from PVKhem Raj12 days1-2/+2
| | | | | | | This causes errors like OSError: [Errno 36] File name too long: Signed-off-by: Khem Raj <raj.khem@gmail.com>
* opencv: Upgrade to 3.4.5Khem Raj12 days3-79/+11
| | | | | | | Drop adding git revs to PV, its not needed since we are on release tag Drop upstreamed patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cpprest: update to 2.10.10Gianfranco Costamagna12 days1-2/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nmap: Include additional FILES path for certsScott Ellis13 days1-1/+1
| | | | | | | | | | If both ncat and ssl are in PACKAGECONFIG then the installer adds a cert bundle to /usr/share/ncat/ca-bundle.crt Signed-off-by: Scott Ellis <scott@jumpnowtek.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nmap: Fix typo in pcre PACKAGECONFIGScott Ellis13 days1-1/+1
| | | | | Signed-off-by: Scott Ellis <scott@jumpnowtek.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lshw: BBCLASSEXTEND to nativeMing Liu13 days1-0/+2
| | | | | | | | In case some recipes might need it, for instance, the aktualizr-native of meta-updater. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* pam-ssh-agent-auth: Port to work with openssl 1.1.xKhem Raj13 days3-2/+1249
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libqmi: Update to 1.22.0William A. Kennington III via Openembedded-devel2019-02-012-44/+3
| | | | | | | | | | | | Giving up on inline patches for now. >From b1fa081fcd795384e37dd2078072e77070559cf1 Mon Sep 17 00:00:00 2001 From: Glenn Stroz <gstroz@uber.com> Date: Wed, 23 Jan 2019 19:58:01 -0500 Subject: [PATCH] libqmi: Upgrade to 1.22.0 Signed-off-by: Glenn Stroz <gstroz@uber.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libwebsockets: upgrade 3.0.0 -> 3.1.0Andreas Müller2019-02-011-1/+1
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libwebsockets: fix multilib installAndreas Müller2019-02-011-0/+4
| | | | | | | | | | | | | | | | | | | | ERROR: libwebsockets-3.0.0-r0 do_package: QA Issue: libwebsockets: Files/directories were installed but not shipped in any package: | /usr/lib/libwebsockets.so | /usr/lib/libwebsockets.a | /usr/lib/libwebsockets.so.13 | /usr/lib/cmake | /usr/lib/pkgconfig | /usr/lib/cmake/libwebsockets | /usr/lib/cmake/libwebsockets/LibwebsocketsTargets-release.cmake | /usr/lib/cmake/libwebsockets/LibwebsocketsConfig.cmake | /usr/lib/cmake/libwebsockets/LibwebsocketsConfigVersion.cmake | /usr/lib/cmake/libwebsockets/LibwebsocketsTargets.cmake | /usr/lib/pkgconfig/libwebsockets_static.pc | /usr/lib/pkgconfig/libwebsockets.pc Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vim: Enable GUI support for x11 DISTRO_FEATURESOvidiu Panait2019-02-011-1/+4
| | | | | | | | | | Adding vim to a sato image will produce a non-working Gvim desktop entry because GUI support is not compiled in: # vim -g E25: GUI cannot be used: Not enabled at compile time Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vim: Fix "--enable-gtk2-test" unrecognized option errorOvidiu Panait2019-02-011-1/+1
| | | | | | | | | | | | | Fix the following build error when vim PACKAGECONFIG[gtkgui] is enabled: ... ERROR: vim-8.1.0347-r0 do_configure: QA Issue: vim: configure was passed unrecognised options: --enable-gtk2-test [unknown-configure-option] ERROR: vim-8.1.0347-r0 do_configure: Fatal QA errors found, failing task. ERROR: vim-8.1.0347-r0 do_configure: Function failed: do_qa_configure ... Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* vim: improve reproducibilityMingli Yu2019-02-012-0/+47
| | | | | | | | | | | Clear all_cflags, all_lflags, compiled_user and compiled_sys to avoid introducing build info to improve reproducibility as below: WARNING: vim-8.1.0347-r0 do_package_qa: QA Issue: File /work/core2-64-wrs-linux/vim/8.1.0347-r0/packages-split/vim/usr/bin/vim.vim in package contained reference to tmpdir [buildpaths] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libgit2: upgrade 0.27.4 -> 0.27.8Andreas Müller2019-01-301-2/+2
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libgit2: Fix install for multilibAndreas Müller2019-01-301-5/+6
| | | | | | | | | | | | | | | | ERROR: libgit2-0.27.4-r0 do_package: QA Issue: libgit2: Files/directories were installed but not shipped in any package: | /usr/lib/libgit2.so.0.27.5 | /usr/lib/libgit2.so.27 | /usr/lib/libgit2.so | /usr/lib/pkgconfig | /usr/lib/pkgconfig/libgit2.pc | Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. + reduce 8 spaces by 4 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libeigen: update from 3.3.5 -> 3.3.7Maxime Roussin-Bélanger2019-01-301-4/+4
| | | | | | | libeigen: switch from http to https Signed-off-by: Maxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* botan: Upgrade to 2.9.0Khem Raj2019-01-301-7/+5
| | | | | | | | | | License-Update: Update copyright years to 2019 https://github.com/randombit/botan/commit/d5edb39e968893bafe87a6a5ef12af45914c0d70#diff-98cd14c95bb22f9d397da0603a77d950 Swith to tarball fetcher Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mozjs: Fix symbol visibility with clang/libc++Khem Raj2019-01-302-0/+38
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* jack: Fix build when using libc++Khem Raj2019-01-302-0/+28
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* asio: Update to 1.12.2Khem Raj2019-01-301-2/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* jsonrpc: Update to 1.1.1Khem Raj2019-01-306-209/+8
| | | | | | | | | | License-Updare: Change in copyright headers https://github.com/cinemast/libjson-rpc-cpp/commit/ba3507a24bd07e89641ecbc7e567c01a754c8d73#diff-61e0bdf7e1b43c5c93d9488b22e04170 Drop all patches since these issues are already fixed in new version add new dependency on hiredis Signed-off-by: Khem Raj <raj.khem@gmail.com>
* xmlrpc-c: Update to 1.51.03Khem Raj2019-01-304-76/+76
| | | | | | Fix build with clang while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinymembench: Fix build with clang assemblerKhem Raj2019-01-302-1/+447
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mosh: Upgrade to 1.3.2Khem Raj2019-01-302-3/+29
| | | | | | Fix building with clang/libc++ while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
* cpuburn-arm: Move cpuburn-neon to cpuburn-arm and add more testsKhem Raj2019-01-305-30/+184
| | | | | | This provides more benchmarks for different arm arches >= v7 Signed-off-by: Khem Raj <raj.khem@gmail.com>
* irssi: Upgrade from 1.0.4 to 1.1.2Randy MacLeod2019-01-301-2/+2
| | | | | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* php: upgrade to 5.6.39Hong Liu2019-01-301-2/+2
| | | | | | | 1.Upgrade php from 5.6.38 to 5.6.39. Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* jq: update to 1.6Alex Kiernan2019-01-302-73/+4
| | | | | | | | | | | | Drop backported patch as it's present in 1.6. Switch to autotools-brokensep to avoid | sed -e 's/\\/\\\\/g' -e 's/"/\\"/g' -e 's/^/"/' -e 's/$/\\n"/' ../jq-1.6/src/builtin.jq > src/builtin.inc | /bin/sh: src/builtin.inc: No such file or directory License-Update: whitespace changes Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libvncserver: make PACKAGECONFIG flags explicitRandy MacLeod2019-01-281-9/+9
| | | | | | | | | Set all the PACKAGECONFIG enable/disable flags explicitly rather than rely on assumed defaults. This also makes it clear what the intended configuration is in log files. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libvncserver: Update to latest commit post 0.9.12Randy MacLeod2019-01-281-1/+4
| | | | | | | | | | | Update to latest git HEAD rather than just 0.9.12 since that includes a fix for CVE-2018-15127. Support for lzo in addition to a bundled minilzo was added upstream so add a PACKAGECONFIG[lzo] and add it to the default config. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* iwd: update to 0.14Stefan Agner2019-01-281-1/+1
| | | | | Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ell: update to 0.17Stefan Agner2019-01-281-1/+1
| | | | | Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* polkit: inherit distro_features_checkStefan Agner2019-01-281-1/+1
| | | | | | | | | Make the recently added REQUIRED_DISTRO_FEATURES effective by inheriting distro_features_check. Fixes: 97a1a55f4755 ("polkit: add polkit as a required distro feature") Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nodejs 8.14.0 -> 8.15.0Matthijs Vader2019-01-281-2/+2
| | | | | | | | Update nodejs to latest 8.x stable release 8.15.0. Signed-off-by: Matthijs Vader <mvader@victronenergy.com> Signed-off-by: Jeroen Hofstee <jhofstee@victronenergy.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libmbim: Upgrade to 1.18.0William A. Kennington III via Openembedded-devel2019-01-282-3/+3
| | | | | | | | | | | | | Accidentally sent outdated patch. This is current. Verified it works with both GCC and clang. >From b1d6d7ae22f7ebcd943493c60e78dea2f9c00a31 Mon Sep 17 00:00:00 2001 From: Glenn Stroz <gstroz@uber.com> Date: Fri, 25 Jan 2019 20:33:57 -0500 Subject: [PATCH] libmbim: Upgrade to 1.18.0 Signed-off-by: Glenn Stroz <gstroz@uber.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nmap: Fix build with clang8/musl/libc++Khem Raj2019-01-283-1/+157
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>