aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb')
-rw-r--r--meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb23
1 files changed, 8 insertions, 15 deletions
diff --git a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
index 5f8c03cc5b..f2e04f7932 100644
--- a/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
+++ b/meta-xfce/recipes-xfce/packagegroups/packagegroup-xfce-extended.bb
@@ -1,21 +1,18 @@
SUMMARY = "All packages for full XFCE installation"
SECTION = "x11/wm"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-PR = "r10"
-inherit packagegroup distro_features_check
+inherit packagegroup features_check
REQUIRED_DISTRO_FEATURES = "x11"
# mandatory
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
packagegroup-xfce-base \
"
# nice to have
-RRECOMMENDS_${PN} = " \
+RRECOMMENDS:${PN} = " \
xfwm4-theme-daloa \
xfwm4-theme-kokodi \
xfwm4-theme-moheli \
@@ -36,39 +33,35 @@ RRECOMMENDS_${PN} = " \
xfce4-systemload-plugin \
xfce4-time-out-plugin \
xfce4-timer-plugin \
- xfce4-embed-plugin \
xfce4-weather-plugin \
xfce4-fsguard-plugin \
xfce4-battery-plugin \
xfce4-mount-plugin \
xfce4-powermanager-plugin \
xfce4-closebutton-plugin \
- xfce4-equake-plugin \
xfce4-notes-plugin \
xfce4-whiskermenu-plugin \
xfce4-mailwatch-plugin \
- xfce4-kbdleds-plugin \
xfce4-smartbookmark-plugin \
- xfce4-hotcorner-plugin \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'xfce4-pulseaudio-plugin', '', d)} \
xfce4-sensors-plugin \
xfce4-calculator-plugin \
xfce4-verve-plugin \
\
- xfce-polkit \
- ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "blueman", "", d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES','polkit','xfce-polkit','',d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth gobject-introspection", "blueman", "", d)} \
\
thunar-media-tags-plugin \
thunar-archive-plugin \
\
xfce4-appfinder \
+ xfce4-screensaver \
xfce4-screenshooter \
xfce4-power-manager \
- xfce4-mixer \
ristretto \
xfce4-taskmanager \
gigolo \
mousepad \
- catfish \
- xfce4-panel-profiles \
+ ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "catfish", "", d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "xfce4-panel-profiles", "", d)} \
"