aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-art
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-art')
-rw-r--r--meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb6
-rw-r--r--meta-xfce/recipes-art/rodent-icon-theme/rodent-icon-theme_5.0.bb10
-rw-r--r--meta-xfce/recipes-art/xfce-dusk-gtk3/xfce-dusk-gtk3_1.3.bb6
-rw-r--r--meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb4
4 files changed, 14 insertions, 12 deletions
diff --git a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
index df0ed50c7b..dc62a1c722 100644
--- a/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
+++ b/meta-xfce/recipes-art/cursor-themes/openzone_1.2.3.bb
@@ -22,10 +22,12 @@ do_install() {
done
}
-python populate_packages_prepend () {
+python populate_packages:prepend () {
icondir = bb.data.expand('${datadir}/icons', d)
do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
}
+FILES:${PN} += "${datadir}/icons"
+
PACKAGES_DYNAMIC += "^openzone-.*"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-xfce/recipes-art/rodent-icon-theme/rodent-icon-theme_5.0.bb b/meta-xfce/recipes-art/rodent-icon-theme/rodent-icon-theme_5.0.bb
index 40ba340f22..532980d967 100644
--- a/meta-xfce/recipes-art/rodent-icon-theme/rodent-icon-theme_5.0.bb
+++ b/meta-xfce/recipes-art/rodent-icon-theme/rodent-icon-theme_5.0.bb
@@ -1,5 +1,5 @@
SUMMARY = "Rodent-icon-theme (was xfce4-icon-theme) is a svg icon theme"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
inherit allarch autotools gtk-icon-cache
@@ -8,9 +8,9 @@ SRC_URI = "http://sourceforge.net/projects/xffm/files/${BPN}/${BPN}-${PV}.tar.gz
SRC_URI[md5sum] = "4b097d344a160d6497c6498985c8df15"
SRC_URI[sha256sum] = "6ed00d16faa1f55b3bb7b13862de1d7f5cfd978b93e42487ded21595d0dbe208"
-FILES_${PN} += "${datadir}/icons"
+FILES:${PN} += "${datadir}/icons"
-RREPLACES_${PN} += "xfce4-icon-theme"
-RPROVIDES_${PN} += "xfce4-icon-theme"
-RCONFLICTS_${PN} += "xfce4-icon-theme"
+RREPLACES:${PN} += "xfce4-icon-theme"
+RPROVIDES:${PN} += "xfce4-icon-theme"
+RCONFLICTS:${PN} += "xfce4-icon-theme"
diff --git a/meta-xfce/recipes-art/xfce-dusk-gtk3/xfce-dusk-gtk3_1.3.bb b/meta-xfce/recipes-art/xfce-dusk-gtk3/xfce-dusk-gtk3_1.3.bb
index b05c748529..4cbdb4e083 100644
--- a/meta-xfce/recipes-art/xfce-dusk-gtk3/xfce-dusk-gtk3_1.3.bb
+++ b/meta-xfce/recipes-art/xfce-dusk-gtk3/xfce-dusk-gtk3_1.3.bb
@@ -1,10 +1,10 @@
SUMMARY = "Modified version of the xfce-dusk theme to support also gtk 3.x too"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8f0e2cd40e05189ec81232da84bd6e1a"
inherit allarch
-SRC_URI = "http://xfce-look.org/CONTENT/content-files/141404-xfce_dusk_gtk3-1_3.tar.gz;subdir=${BPN}-${PV}"
+SRC_URI = "http://sources.openembedded.org/141404-xfce_dusk_gtk3-1_3.tar.gz;subdir=${BPN}-${PV}"
SRC_URI[md5sum] = "b3ad37ad8173b14ec090e60a80e65d8f"
SRC_URI[sha256sum] = "bfa8a88607d1a1da5bd0b9e4e075767c54400a3c5a0fae88b619ed71532f30b4"
@@ -16,4 +16,4 @@ do_install() {
cp -r Xfce-dusk-gtk3 ${D}${datadir}/themes/Xfce-dusk-gtk3
}
-FILES_${PN} = "${datadir}/themes"
+FILES:${PN} = "${datadir}/themes"
diff --git a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
index 7030f7a267..272f83c01b 100644
--- a/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
+++ b/meta-xfce/recipes-art/xfwm4-themes/xfwm4-themes_4.10.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "Additional (old) themes for Xfwm4"
SECTION = "x11/wm"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
inherit xfce
@@ -11,7 +11,7 @@ SRC_URI[sha256sum] = "3214d5f00e9703b5e8c9e7c3287d606dedec7285ceb4d5db332e93ada6
# using xfwm4-theme as in xfwm4 might cause warnings of packages supplied by
# multiple providers. So we use xfwm4-old-theme here.
-python populate_packages_prepend () {
+python populate_packages:prepend () {
themedir = d.expand('${datadir}/themes')
do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
}