aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-requests.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.18.1.bb (renamed from meta-python/recipes-devtools/python/python-requests_2.13.0.bb)2
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.18.1.bb (renamed from meta-python/recipes-devtools/python/python3-requests_2.13.0.bb)2
3 files changed, 9 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests.inc b/meta-python/recipes-devtools/python/python-requests.inc
index b66f66e117..81819bf243 100644
--- a/meta-python/recipes-devtools/python/python-requests.inc
+++ b/meta-python/recipes-devtools/python/python-requests.inc
@@ -1,10 +1,12 @@
DESCRIPTION = "Python HTTP for Humans."
HOMEPAGE = "http://python-requests.org"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9bb3515869c0f426cb8441c899ae7f5"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=979d6a23b143e13ea0e5e3aa81248820"
-SRC_URI[md5sum] = "921ec6b48f2ddafc8bb6160957baf444"
-SRC_URI[sha256sum] = "5722cd09762faa01276230270ff16af7acf7c5c45d623868d9ba116f15791ce8"
+SRC_URI[md5sum] = "40f723ed01dddeaf990d0609d073f021"
+SRC_URI[sha256sum] = "c6f3bdf4a4323ac7b45d01e04a6f6c20e32a052cd04de81e05103abc049ad9b9"
+
+inherit pypi
RDEPENDS_${PN} += " \
${PYTHON_PN}-email \
@@ -15,6 +17,8 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-pyopenssl \
${PYTHON_PN}-pysocks \
${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna \
"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.13.0.bb b/meta-python/recipes-devtools/python/python-requests_2.18.1.bb
index 627bc95d8a..0d7a29f745 100644
--- a/meta-python/recipes-devtools/python/python-requests_2.13.0.bb
+++ b/meta-python/recipes-devtools/python/python-requests_2.18.1.bb
@@ -1,4 +1,4 @@
-inherit pypi setuptools
+inherit setuptools
require python-requests.inc
RDEPENDS_${PN} += "${PYTHON_PN}-zlib"
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.18.1.bb
index 5e869b7883..d91d993bf2 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.13.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.18.1.bb
@@ -1,4 +1,4 @@
-inherit pypi setuptools3
+inherit setuptools3
require python-requests.inc
# Add the runtime depends for selectors.py