aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-cython_0.20.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-python/python-cython_0.20.2.bb')
-rw-r--r--meta-python/recipes-python/python-cython_0.20.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-cython_0.20.2.bb b/meta-python/recipes-python/python-cython_0.20.2.bb
new file mode 100644
index 0000000000..9f357ec04a
--- /dev/null
+++ b/meta-python/recipes-python/python-cython_0.20.2.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+SRCNAME = "Cython"
+BBCLASSEXTEND = "native"
+
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "7fc13e1c665bdf7cea19ad08906af91f"
+SRC_URI[sha256sum] = "ed13b606a2aeb5bd6c235f8ed6c9988c99d01a033d0d21d56137c13d5c7be63f"
+
+inherit setuptools