aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb b/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
deleted file mode 100644
index 3e4374ed4b..0000000000
--- a/meta-python/recipes-devtools/python/python3-werkzeug_1.0.0.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-SUMMARY = "The Swiss Army knife of Python web development"
-DESCRIPTION = "\
-Werkzeug started as simple collection of various utilities for WSGI \
-applications and has become one of the most advanced WSGI utility modules. \
-It includes a powerful debugger, full featured request and response objects, \
-HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
-cookie handling, file uploads, a powerful URL routing system and a bunch \
-of community contributed addon modules."
-HOMEPAGE = "http://werkzeug.pocoo.org/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
-
-SRC_URI[md5sum] = "305f75c4a88c96dcdc5654bf2d01bc05"
-SRC_URI[sha256sum] = "169ba8a33788476292d04186ab33b01d6add475033dfc07215e6d219cc077096"
-
-PYPI_PACKAGE = "Werkzeug"
-
-inherit pypi setuptools3
-
-CLEANBROKEN = "1"
-
-PACKAGES =+ "${PN}-tests"
-FILES_${PN}-tests+= " \
- ${PYTHON_SITEPACKAGES_DIR}/werkzeug/test* \
- ${PYTHON_SITEPACKAGES_DIR}/werkzeug/__pycache__/test* \
- ${PYTHON_SITEPACKAGES_DIR}/werkzeug/contrib/test* \
- ${PYTHON_SITEPACKAGES_DIR}/werkzeug/contrib/__pycache__/test* \
-"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-difflib \
- ${PYTHON_PN}-email \
- ${PYTHON_PN}-html \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-misc \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-netserver \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-pkgutil \
- ${PYTHON_PN}-pprint \
- ${PYTHON_PN}-threading \
- ${PYTHON_PN}-unixadmin \
-"
-
-RDEPENDS_${PN}-tests = " \
- ${PN} \
- ${PYTHON_PN}-unittest \
-"