aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb
new file mode 100644
index 0000000000..77d26f54b2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.66.2.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=42dfa9e8c616dbc295df3f58d756b2a1"
+
+SRC_URI[sha256sum] = "6cd52cdf0fef0e0f543299cfc96fec90d7b8a7e88745f411ec33eb44d5ed3531"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-logging \
+ python3-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"