aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb
new file mode 100644
index 0000000000..e646bd0d9c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.29.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
+
+SRC_URI[sha256sum] = "bd9566b8e58cabd700bc367b60e90d9349cd16f0984973f98a9a09f9c64e86f0"
+
+PYPI_PACKAGE = "SQLAlchemy"
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-asyncio \
+ python3-compression \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-numbers \
+ python3-pickle \
+ python3-profile \
+ python3-threading \
+ python3-typing-extensions \
+"
+
+BBCLASSEXTEND = "native nativesdk"