aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-smbus_4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-smbus_4.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-smbus_4.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smbus_4.3.bb b/meta-python/recipes-devtools/python/python3-smbus_4.3.bb
new file mode 100644
index 0000000000..b305a128a2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-smbus_4.3.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Set of i2c tools for linux - Python module"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://py-smbus/smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz \
+ file://0001-Use-setuptools-as-distutils-is-deprecated.patch \
+ "
+SRC_URI[sha256sum] = "eec464e42301d93586cbeca3845ed61bff40f560670e5b35baec57301d438148"
+
+DEPENDS += "i2c-tools"
+
+S = "${WORKDIR}/i2c-tools-${PV}"
+
+inherit setuptools3
+
+SETUPTOOLS_SETUP_PATH = "${S}/py-smbus"