aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb b/meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb
new file mode 100644
index 0000000000..26bc71762e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sdbus_0.11.1.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Modern Python library for the systemd D-Bus"
+HOMEPAGE = "https://python-sdbus.readthedocs.io/en/latest/"
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e77986dc8e2ee22d44a7c863e96852ae"
+
+SRC_URI[sha256sum] = "adb97718ce996bb308520682c50b1a13e606d65a6edb1c1967a15d2e570cb3b7"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+DEPENDS += "systemd"
+
+RDEPENDS:${PN} += " \
+ python3-asyncio \
+ python3-numbers \
+ python3-core \
+"
+
+inherit pypi setuptools3 features_check pkgconfig