aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
new file mode 100644
index 0000000000..ed5175fcf7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A libudev binding"
+
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI[sha256sum] = "75e54d37218f5ac45b0da1f0fd9cc5e526a3cac3ef1cfad410cf7ab338b01471"
+
+inherit pypi setuptools3
+
+do_configure:prepend() {
+ sed -i "/import pyudev/d" ${S}/setup.py
+ sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
+}
+
+RDEPENDS:${PN} = "\
+ python3-ctypes \
+ python3-misc \
+ python3-six \
+ python3-threading \
+ python3-fcntl \
+ libudev \
+"