aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb b/meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb
new file mode 100644
index 0000000000..163a363f82
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-metadata_2.0.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "pytest-metadata is a plugin that allowed for accessing pytest metadata"
+DEPENDS += "python3-setuptools-scm-native"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
+
+SRC_URI[sha256sum] = "fcd2f416f15be295943527b3c8ba16a44ae5a7141939c90c3dc5ce9d167cf2a5"
+
+PYPI_PACKAGE = "pytest-metadata"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = " \
+ python3-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"