aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb b/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb
new file mode 100644
index 0000000000..292ceab2e3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyfanotify_0.2.2.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python wrapper for Linux fanotify."
+HOMEPAGE = "https://github.com/baskiton/pyfanotify"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=636a36c9df04efcfacf839b8866d9a37"
+
+SRC_URI += "file://0001-ext-define-FNM_EXTMATCH-if-not-already-defined.patch"
+SRC_URI[sha256sum] = "90219aa9f8b78fa732f24aa7b21c7bb6ac97a6eb47f1763c899b8194e23af1df"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-crypt \
+ python3-datetime \
+ python3-logging \
+ python3-multiprocessing \
+"