aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb
new file mode 100644
index 0000000000..a6863e21ff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.45.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPL-2.0-only | MIT"
+LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=be42e1b1e58c8d59c2901fd747bfc55d \
+ "
+
+SRC_URI[sha256sum] = "5730590be0271364a5bddd9e245c9cc0fb710c4cbacbdd95264a3122d23224ca"
+
+DEPENDS = "curl"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"