aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb b/meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb
new file mode 100644
index 0000000000..68507e2482
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pep8_1.7.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python style guide checker"
+HOMEPAGE = "https://github.com/PyCQA/pycodestyle"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=d8ebbbe831259ce010179d2f310b0f3e"
+
+SRC_URI[md5sum] = "a03bb494859e87b42601b61b1b043a0c"
+SRC_URI[sha256sum] = "603a46e5c358ce20ac4807a0eeafac7505d1125a4c1bd8378757ada06f61bed8"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-prettytable \
+ python3-cmd2 \
+ python3-pyparsing"
+
+SRC_URI[md5sum] = "603821d06db945c71d811b5a8d78423c"
+SRC_URI[sha256sum] = "fe249b52e20498e59e0b5c5256aa52ee99fc295b26ec9eaa85776ffdb9fe6374"