aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb b/meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb
new file mode 100644
index 0000000000..97786ff456
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-luma-core_1.17.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A component library to support SBC display drivers"
+DESCRIPTION = "A component library to support SBC display drivers"
+HOMEPAGE = "https://github.com/rm-hull/luma.core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=eda804060ba2312e41fe96b6fa334fd7"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "4e4a5e85ccf19eba001d11d95b33b174"
+SRC_URI[sha256sum] = "d66b98e23470f023a6423273e9632180a1a941849f1417c69a708ca51861c993"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "luma.core"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pillow \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-smbus2 \
+"