aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-isort_5.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-isort_5.13.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_5.13.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-isort_5.13.2.bb b/meta-python/recipes-devtools/python/python3-isort_5.13.2.bb
new file mode 100644
index 0000000000..60d44181c0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-isort_5.13.2.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[sha256sum] = "48fdfcb9face5d58a4f6dde2e72a1fb8dcaf8ab26f95ab49fab84c2ddefb0109"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+ python3-compression \
+ python3-datetime \
+ python3-difflib \
+ python3-email \
+ python3-numbers \
+ python3-pprint \
+ python3-profile \
+ python3-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"