aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb b/meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb
new file mode 100644
index 0000000000..da1eea4cf7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanize_4.9.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[sha256sum] = "582a265c931c683a7e9b8ed9559089dea7edcf6cc95be39a3cbc2c5d5ac2bcfa"
+
+inherit pypi python_hatchling
+
+DEPENDS += "\
+ python3-setuptools-scm-native \
+ python3-hatch-vcs-native \
+"
+
+RDEPENDS:${PN} += "\
+ python3-datetime \
+ python3-setuptools \
+"
+
+BBCLASSEXTEND = "native nativesdk"