aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb b/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
new file mode 100644
index 0000000000..e4d3cbeee8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
@@ -0,0 +1,48 @@
+SUMMARY = "A next generation HTTP client for Python."
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c624803bdf6fc1c4ce39f5ae11d7bd05"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "a0cb88a46f32dc874e04ee956e4c2764aba2aa228f650b06788ba6bda2962ab5"
+
+DEPENDS += "\
+ python3-hatch-fancy-pypi-readme-native \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[brotli] = ",,,python3-brotli"
+PACKAGECONFIG[http2] = ",,,python3-h2"
+PACKAGECONFIG[socks] = ",,,python3-socksio"
+
+RDEPENDS:${PN} += "\
+ python3-anyio \
+ python3-certifi \
+ python3-httpcore \
+ python3-idna \
+ python3-sniffio \
+ python3-json \
+ python3-core \
+ python3-netclient \
+ python3-compression \
+"
+
+PACKAGES += "\
+ ${PN}-cli \
+"
+
+RDEPENDS:${PN}-cli += "\
+ ${PN} \
+ python3-click \
+ python3-pygments \
+ python3-rich \
+"
+
+FILES:${PN} = "\
+ ${libdir}/${PYTHON_DIR} \
+"
+
+FILES:${PN}-cli = "\
+ ${bindir}/httpx \
+"