aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb
new file mode 100644
index 0000000000..6a27006b79
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.118.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
+Moderator, and many other Google APIs."
+HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "ebf4927a3f5184096647be8f705d090e7f06d48ad82b0fa431a2fe80c2cbe182"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-logging \
+ python3-six \
+ python3-json \
+ python3-core \
+ python3-netclient \
+ python3-httplib2 \
+ python3-uritemplate \
+ python3-google-api-core \
+"