aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb b/meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb
new file mode 100644
index 0000000000..a0454686ee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-betamax_0.9.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "VCR imitation for python requests"
+HOMEPAGE = "https://github.com/betamaxpy/betamax"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c"
+
+SRC_URI += " \
+ file://run-ptest \
+ file://0001-Drop-ptests-fixtures-and-recorde_modes.patch \
+"
+SRC_URI[sha256sum] = "82316e1679bc6879e3c83318d016b54b7c9225ff08c4462de4813e22038d5f94"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS:${PN} += " \
+ python3-requests \
+ python3-unittest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}