aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
new file mode 100644
index 0000000000..cfdbde9689
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.4.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI[sha256sum] = "2d63a8c573417bae338962d4b9b06fbc6080f74ecd955a092849e1e65c717bd2"
+
+DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+RDEPENDS:${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+BBCLASSEXTEND = "native"