aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-mock_3.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-mock_3.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-mock_3.0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-mock_3.0.5.bb b/meta-python/recipes-devtools/python/python-mock_3.0.5.bb
new file mode 100644
index 0000000000..db71066495
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-mock_3.0.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A Python Mocking and Patching Library for Testing"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
+
+SRC_URI[md5sum] = "d834a46d9a129be3e76fdcc99751e82c"
+SRC_URI[sha256sum] = "83657d894c90d5681d62155c82bda9c1187827525880eda8ff5df4ec813437c3"
+
+inherit pypi setuptools
+
+DEPENDS += " \
+ python-pbr-native"
+
+RDEPENDS_${PN} += " \
+ python-prettytable \
+ python-cmd2 \
+ python-pyparsing \
+ python-mccabe \
+ python-pep8 \
+ python-pyflakes \
+ python-pbr \
+ python-funcsigs \
+"