aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libio
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libio')
-rw-r--r--meta-perl/recipes-perl/libio/files/run-ptest16
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.206.bb24
-rw-r--r--meta-perl/recipes-perl/libio/libio-compress-perl_2.206.bb41
-rw-r--r--meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.085.bb (renamed from meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.060.bb)41
-rw-r--r--meta-perl/recipes-perl/libio/libio-stringy-perl_2.111.bb4
5 files changed, 91 insertions, 35 deletions
diff --git a/meta-perl/recipes-perl/libio/files/run-ptest b/meta-perl/recipes-perl/libio/files/run-ptest
deleted file mode 100644
index c9f9ca94d0..0000000000
--- a/meta-perl/recipes-perl/libio/files/run-ptest
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-for case in `find t -type f -name '*.t'`; do
- perl $case >$case.output 2>&1
- ret=$?
- cat $case.output
- if [ $ret -ne 0 ]; then
- echo "FAIL: ${case%.t}"
- elif grep -i 'SKIP' $case.output; then
- echo "SKIP: ${case%.t}"
- else
- echo "PASS: ${case%.t}"
- fi
-
- rm -f $case.output
-done
diff --git a/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.206.bb b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.206.bb
new file mode 100644
index 0000000000..1959df5e04
--- /dev/null
+++ b/meta-perl/recipes-perl/libio/libio-compress-lzma-perl_2.206.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Perl interface to allow reading and writing of lzma files/buffers."
+DESCRIPTION = "This module provides a Perl interface to allow reading and \
+writing of lzma files/buffers."
+HOMEPAGE = "https://metacpan.org/release/IO-Compress-Lzma"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=b95311d4a7dbf3d0d3663edc094aced6"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-Lzma-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "6c600f9bbb1a2d834b1decd0bd5863dcea52e0ac17de101b5085e0e3cb27285c"
+
+S = "${WORKDIR}/IO-Compress-Lzma-${PV}"
+
+inherit cpan
+
+RDEPENDS:${PN} += "\
+ perl-module-autoloader \
+ libcompress-raw-lzma-perl \
+ libio-compress-perl \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libio/libio-compress-perl_2.206.bb b/meta-perl/recipes-perl/libio/libio-compress-perl_2.206.bb
new file mode 100644
index 0000000000..c58e3fa30c
--- /dev/null
+++ b/meta-perl/recipes-perl/libio/libio-compress-perl_2.206.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Perl interface to allow reading and writing of compressed data."
+DESCRIPTION = "This distribution provides a Perl interface to allow reading \
+and writing of compressed data created with the zlib and bzip2. \
+\
+IO-Compress supports reading and writing of the following compressed data \
+formats \
+ * bzip2 \
+ * RFC 1950 \
+ * RFC 1951 \
+ * RFC 1952 (i.e. gzip) \
+ * zip \
+"
+HOMEPAGE = "https://metacpan.org/release/IO-Compress"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=8e78b88f9c8ac08ae03e8ea81195ca45"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "7d3062b9a494f757e8d0614f220d83f22731bbda1aeb5f7cff0e72a83f433d35"
+
+S = "${WORKDIR}/IO-Compress-${PV}"
+
+inherit cpan
+
+RDEPENDS:${PN} += "\
+ perl-module-bytes \
+ perl-module-cwd \
+ perl-module-encode \
+ perl-module-file-glob \
+ perl-module-file-spec \
+ perl-module-posix \
+ perl-module-scalar-util \
+ perl-module-time-local \
+ perl-module-utf8 \
+ libcompress-raw-bzip2-perl \
+ libcompress-raw-zlib-perl \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.060.bb b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.085.bb
index 20f8808291..f7b3d416df 100644
--- a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.060.bb
+++ b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.085.bb
@@ -9,39 +9,46 @@ mod_perl."
HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
SECTION = "libs"
-LICENSE = "Artistic-1.0|GPLv1+"
-LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+LIC_FILES_CHKSUM = "file://META.yml;beginline=12;endline=12;md5=963ce28228347875ace682de56eef8e8"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
+ libmozilla-ca-perl \
libnet-ssleay-perl \
perl-module-autoloader \
- perl-module-scalar-util \
perl-module-io-socket \
+ perl-module-scalar-util \
"
-SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
- file://run-ptest \
- "
-SRC_URI[md5sum] = "97fa6cd64f15db60f810cd8ab02d57fc"
-SRC_URI[sha256sum] = "fb5b2877ac5b686a5d7b8dd71cf5464ffe75d10c32047b5570674870e46b1b8c"
+SRC_URI = "${CPAN_MIRROR}/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz"
+SRC_URI[sha256sum] = "95b2f7c0628a7e246a159665fbf0620d0d7835e3a940f22d3fdd47c3aa799c2e"
S = "${WORKDIR}/IO-Socket-SSL-${PV}"
-inherit cpan ptest
+inherit cpan ptest-perl
-do_install_append () {
+do_install:append () {
mkdir -p ${D}${docdir}/${PN}/
cp ${S}/BUGS ${D}${docdir}/${PN}/
cp ${S}/Changes ${D}${docdir}/${PN}/
cp ${S}/README ${D}${docdir}/${PN}/
cp -pRP ${S}/docs ${D}${docdir}/${PN}/
- cp -pRP ${S}/certs ${D}${docdir}/${PN}/
+ cp -pRP ${S}/t/certs ${D}${docdir}/${PN}/
cp -pRP ${S}/example ${D}${docdir}/${PN}/
}
-do_install_ptest () {
- cp -r ${B}/t ${D}${PTEST_PATH}
- cp -r ${B}/certs ${D}${PTEST_PATH}
-}
+RDEPENDS:${PN}-ptest += "\
+ libnet-idn-encode \
+ liburi-perl \
+ perl-module-file-glob \
+ perl-module-findbin \
+ perl-module-io-socket-inet \
+ perl-module-io-socket-ip \
+ perl-module-perlio \
+ perl-module-perlio-scalar \
+ perl-module-test-more \
+"
-BBCLASSEXTEND = "native"
+do_install_ptest:append () {
+ cp -r ${B}/t/certs ${D}${PTEST_PATH}
+}
diff --git a/meta-perl/recipes-perl/libio/libio-stringy-perl_2.111.bb b/meta-perl/recipes-perl/libio/libio-stringy-perl_2.111.bb
index 0e566c0f23..b745939234 100644
--- a/meta-perl/recipes-perl/libio/libio-stringy-perl_2.111.bb
+++ b/meta-perl/recipes-perl/libio/libio-stringy-perl_2.111.bb
@@ -5,7 +5,7 @@ filehandles; in particular, IO::Scalar, IO::ScalarArray, and IO::Lines."
HOMEPAGE = "http://www.zeegee.com/products/IO-stringy/"
SECTION = "devel"
-LICENSE = "Artistic-1.0 | GPL-1.0+"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=01406e4ff2e60d88d42ef1caebdd0011"
@@ -17,7 +17,7 @@ S = "${WORKDIR}/IO-stringy-${PV}"
inherit cpan
-RPROVIDES_${PN} += " libio-atomicfile-perl \
+RPROVIDES:${PN} += " libio-atomicfile-perl \
libio-innerfile-perl \
libio-lines-perl \
libio-scalar-perl \