aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb')
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb
new file mode 100644
index 0000000000..47fe8e0035
--- /dev/null
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.206.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Perl interface to the zlib compression library."
+DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
+to the zlib compression library (see 'AUTHOR' for details about where to \
+get zlib)."
+HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=45bba5fa4937353fd4f505fa2108a6bf"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "46785a6a383a1c843895b7f9f25d5d759e7c305159f9d1e04a3604eb74c77374"
+
+DEPENDS += "zlib"
+
+S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
+
+inherit cpan
+
+export BUILD_ZLIB="0"
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+BBCLASSEXTEND = "native"