aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-float-tests.patch25
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch142
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-test-timeouts.patch103
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest_2.10.9.bb (renamed from meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb)7
4 files changed, 2 insertions, 275 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-float-tests.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-float-tests.patch
deleted file mode 100644
index 75f74ec658..0000000000
--- a/meta-oe/recipes-support/cpprest/cpprest/disable-float-tests.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: new toolchain might have increased the float precision
-Author: Gianfranco Costamagna <locutusofborg@debian.org>
-Last-Update: 2017-10-28
-Forwarded: https://github.com/Microsoft/cpprestsdk/issues/576
-
---- casablanca-2.10.0.orig/Release/tests/functional/streams/istream_tests.cpp
-+++ casablanca-2.10.0/Release/tests/functional/streams/istream_tests.cpp
-@@ -1302,7 +1302,7 @@ void compare_float(float expected, float
- {
- compare_floating(expected, actual, FLT_EPSILON);
- }
--
-+/*
- TEST(extract_floating_point)
- {
- std::string test_string;
-@@ -1349,7 +1349,7 @@ TEST(extract_floating_point)
- VERIFY_ARE_EQUAL(1 / expected, 1 / actual);
- } while (!std_istream.eof());
- }
--
-+*/
- TEST(extract_floating_point_with_exceptions)
- {
- std::vector<std::pair<std::string, std::string>> tests;
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
deleted file mode 100644
index 2dff0d97c7..0000000000
--- a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-Description: Debian forbids calls to external websites.
-
-Author: Gianfranco Costamagna <locutus@debian.org>
-Origin: Debian
-Forwarded: not-needed
-Reviewed-By: Gianfranco Costamagna <locutusofborg@debian.org>
-Last-Update: 2015-11-25
-
-Index: casablanca/Release/tests/functional/http/client/CMakeLists.txt
-===================================================================
---- casablanca.orig/Release/tests/functional/http/client/CMakeLists.txt
-+++ casablanca/Release/tests/functional/http/client/CMakeLists.txt
-@@ -12,7 +12,6 @@
- multiple_requests.cpp
- oauth1_tests.cpp
- oauth2_tests.cpp
-- outside_tests.cpp
- pipeline_stage_tests.cpp
- progress_handler_tests.cpp
- proxy_tests.cpp
-Index: casablanca/Release/tests/functional/http/client/authentication_tests.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/http/client/authentication_tests.cpp
-+++ casablanca/Release/tests/functional/http/client/authentication_tests.cpp
-@@ -663,15 +663,19 @@
- VERIFY_ARE_EQUAL(return_code, response.status_code());
- }
-
-+/*
- TEST(auth_no_data)
- {
- auth_test_impl(false);
- }
-+*/
-
-+/*
- TEST(unsuccessful_auth_with_basic_cred)
- {
- auth_test_impl(true);
- }
-+*/
-
- TEST_FIXTURE(uri_address, set_user_options_asio_http)
- {
-@@ -692,7 +696,7 @@
- auto response = client.request(methods::GET).get();
- VERIFY_ARE_EQUAL(200, response.status_code());
- }
--
-+/*
- TEST_FIXTURE(uri_address, set_user_options_asio_https)
- {
- handle_timeout([]
-@@ -714,7 +718,7 @@
- VERIFY_IS_FALSE(v.empty());
- });
- }
--
-+*/
- #endif
-
- } // SUITE(authentication_tests)
-Index: casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
-+++ casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
-@@ -86,7 +86,7 @@
- }
- return false;
- }
--
-+/*
- TEST(ssl_test)
- {
- websocket_client client;
-@@ -122,7 +122,7 @@
- throw;
- }
- }
--
-+*/
- // These tests are specific to our websocketpp based implementation.
- #if !defined(__cplusplus_winrt)
-
-@@ -153,14 +153,15 @@
- throw;
- }
- }
--
-+/*
- // Test specifically for server SignalR team hit interesting cases with.
- TEST(sni_with_older_server_test)
- {
- websocket_client client;
- sni_test_impl(client);
- }
--
-+*/
-+/*
- // WinRT doesn't expose option for disabling.
- // No stable server is available to reliably test this.
- // The configuration below relies on a timeout in the success case.
-@@ -188,7 +189,8 @@
- throw;
- }
- }
--
-+*/
-+/*
- // Winrt doesn't allow explicitly setting server host for SNI.
- TEST(sni_explicit_hostname)
- {
-@@ -199,7 +201,7 @@
- websocket_client client(config);
- sni_test_impl(client);
- }
--
-+*/
- void handshake_error_test_impl(const ::utility::string_t &host)
- {
- websocket_client client;
-Index: casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/http/client/connections_and_errors.cpp
-+++ casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
-@@ -415,6 +415,7 @@
- }
- #endif
-
-+/*
- // Try to connect to a server on a closed port and cancel the operation.
- TEST_FIXTURE(uri_address, cancel_bad_port)
- {
-@@ -446,7 +447,7 @@
-
- VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
- }
--
-+*/
- } // SUITE(connections_and_errors)
-
- }}}}
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-test-timeouts.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-test-timeouts.patch
deleted file mode 100644
index 93c3e8a269..0000000000
--- a/meta-oe/recipes-support/cpprest/cpprest/disable-test-timeouts.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-Description: Some tests takes too long on slow architectures and timeouts
- We can safely disable them.
- e.g.
- Release/tests/functional/http/client/connections_and_errors.cpp:142: error: Failure in request_timeout_microsecond: Test case timed out and is hung. Aborting all remaining test cases. Expected under 180000ms. FAILED
-
-Index: casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/http/client/connections_and_errors.cpp
-+++ casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
-@@ -127,7 +127,7 @@
- // Try sending another request.
- VERIFY_THROWS(client.request(methods::GET).wait(), web::http::http_exception);
- }
--
-+/*
- TEST_FIXTURE(uri_address, request_timeout)
- {
- test_http_server::scoped_server scoped(m_uri);
-@@ -146,7 +146,8 @@
- #endif
- t.get();
- }
--
-+*/
-+/*
- TEST_FIXTURE(uri_address, request_timeout_microsecond)
- {
- pplx::task<test_request*> t;
-@@ -168,7 +169,7 @@
- try { t.get(); }
- catch (...) {}
- }
--
-+*/
- TEST_FIXTURE(uri_address, invalid_method)
- {
- web::http::uri uri(U("http://www.bing.com/"));
-Index: casablanca/Release/tests/functional/http/listener/requests_tests.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/http/listener/requests_tests.cpp
-+++ casablanca/Release/tests/functional/http/listener/requests_tests.cpp
-@@ -173,7 +173,7 @@
-
- listener.close().wait();
- }
--
-+/*
- TEST_FIXTURE(uri_address, response_order)
- {
- http_listener listener(m_uri);
-@@ -217,7 +217,7 @@
-
- listener.close().wait();
- }
--
-+*/
- TEST_FIXTURE(uri_address, uri_encoding, "Ignore", "Codeplex 201")
- {
- http_listener listener(m_uri);
-Index: casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
-+++ casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
-@@ -221,7 +221,7 @@
- VERIFY_ARE_EQUAL("TLS handshake failed", e.error_code().message());
- }
- }
--
-+/*
- TEST(self_signed_cert)
- {
- handshake_error_test_impl(U("wss://self-signed.badssl.com/"));
-@@ -236,7 +236,7 @@
- {
- handshake_error_test_impl(U("wss://expired.badssl.com/"));
- }
--
-+*/
- #endif
-
- } // SUITE(authentication_tests)
-Index: casablanca/Release/tests/functional/websockets/client/client_construction.cpp
-===================================================================
---- casablanca.orig/Release/tests/functional/websockets/client/client_construction.cpp
-+++ casablanca/Release/tests/functional/websockets/client/client_construction.cpp
-@@ -81,7 +81,7 @@
- VERIFY_ARE_EQUAL(config2.credentials().username(), cred.username());
- }
-
--
-+/*
- // Verify that we can get the baseuri from websocket_client connect.
- TEST_FIXTURE(uri_address, uri_test)
- {
-@@ -101,7 +101,7 @@
- VERIFY_ARE_EQUAL(client2.uri(), m_uri);
- client2.close().wait();
- }
--
-+*/
- TEST_FIXTURE(uri_address, move_operations)
- {
- std::string body("hello");
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.9.bb
index b4b1c81e83..4bdc5c682a 100644
--- a/meta-oe/recipes-support/cpprest/cpprest_2.10.8.bb
+++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.9.bb
@@ -8,13 +8,10 @@ DEPENDS = "openssl websocketpp zlib boost brotli"
EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF"
SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
- file://disable-outside-tests.patch \
- file://disable-test-timeouts.patch \
- file://disable-float-tests.patch \
"
-# tag 2.10.8
-SRCREV= "204a52610234ac5180e80a6883b62c0ad085f51e"
+# tag 2.10.9
+SRCREV= "8f0393dd7be08f2d9b44cc09b8b97f9bafb109a5"
S = "${WORKDIR}/git"