aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pidgin/icyque_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/pidgin/icyque_git.bb')
-rw-r--r--meta-oe/recipes-support/pidgin/icyque_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/icyque_git.bb b/meta-oe/recipes-support/pidgin/icyque_git.bb
new file mode 100644
index 0000000000..ed58c4a76f
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/icyque_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "WIM Protocol plugin for ICQ for Adium, Pidgin, Miranda and Telepathy IM Framework"
+SECTION = "webos/services"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+DEPENDS = "pidgin json-glib"
+
+PV = "0.1+git"
+
+inherit pkgconfig
+
+SRC_URI = "git://github.com/EionRobb/icyque;branch=master;protocol=https"
+SRCREV = "513fc162d5d1a201c2b044e2b42941436d1069d5"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake;
+}
+
+do_install() {
+ oe_runmake DESTDIR="${D}" install;
+}
+
+FILES:${PN} += " \
+ ${libdir} \
+"