aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/driverctl/driverctl_0.115.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/driverctl/driverctl_0.115.bb')
-rw-r--r--meta-oe/recipes-support/driverctl/driverctl_0.115.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/driverctl/driverctl_0.115.bb b/meta-oe/recipes-support/driverctl/driverctl_0.115.bb
new file mode 100644
index 0000000000..970844f982
--- /dev/null
+++ b/meta-oe/recipes-support/driverctl/driverctl_0.115.bb
@@ -0,0 +1,26 @@
+SUMMARY = "driverctl is a device driver control utility for Linux"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+DEPENDS = "systemd"
+RDEPENDS:${PN} += "bash bash-completion"
+
+SRC_URI = "git://gitlab.com/driverctl/driverctl.git;branch=master;protocol=https"
+SRCREV = "2ba60536eb20ca0a6a751bd8b6501dba84ec45d3"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig systemd features_check
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES:${PN} += " \
+ ${libdir} \
+ ${datadir} \
+ ${systemd_system_unitdir} \
+"
+