aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb')
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb b/meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb
new file mode 100644
index 0000000000..6565097334
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp_3.7.2.bb
@@ -0,0 +1,23 @@
+SUMMARY = "read temperature sensors in a 1-Wire net"
+SECTION = "util"
+DEPENDS = "libusb1"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
+
+SRC_URI = "git://github.com/bcl/digitemp;branch=master;protocol=https"
+
+SRCREV = "a162e63aad35358aab325388f3d5e88121606419"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "ds9097 ds9097u \
+ SYSTYPE='Linux' \
+"
+do_configure() {
+ rm -f digitemp_*
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 digitemp_* ${D}${sbindir}
+}