aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/geoclue
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-navigation/geoclue')
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue/0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch30
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb (renamed from meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb)41
2 files changed, 54 insertions, 17 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue/0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch b/meta-oe/recipes-navigation/geoclue/geoclue/0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch
new file mode 100644
index 0000000000..18e7185649
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue/0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch
@@ -0,0 +1,30 @@
+From 6c434bdd31d674f85a82cb83248571813c7a37ff Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Wed, 3 May 2023 18:06:46 +0200
+Subject: [PATCH] libgeoclue: don't try to use g-ir-scanner when introspection
+ isn't enabled
+
+* it finds target g-ir-scanner, so gir is found(), but when it tries to call it, it fails:
+ http://errors.yoctoproject.org/Errors/Details/702778/
+ geoclue/2.7.0-r0/recipe-sysroot/usr/bin/g-ir-scanner-wrapper: line 5: g-ir-scanner: command not found
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+Upstream-Status: Pending
+
+ libgeoclue/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgeoclue/meson.build b/libgeoclue/meson.build
+index 5f05dad..7ed06a1 100644
+--- a/libgeoclue/meson.build
++++ b/libgeoclue/meson.build
+@@ -77,7 +77,7 @@ gir_sources = [ libgeoclue_sources,
+ libgeoclue_headers,
+ libgeoclue_public_api_gen_sources[1] ]
+
+-if gir.found()
++if gir.found() and get_option('introspection')
+ geo_gir = gnome.generate_gir(libgeoclue,
+ sources: gir_sources,
+ namespace: 'Geoclue',
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb
index e57e7a7209..9fcd1e6f1e 100644
--- a/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.7.1.bb
@@ -3,52 +3,59 @@ DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
The primary goal of the Geoclue project is to make creating location-aware applications \
as simple as possible, while the secondary goal is to ensure that no application \
can access location information without explicit permission from user."
-LICENSE = "GPLv2.0+"
+LICENSE = "GPL-2.0-or-later"
SECTION = "console/network"
LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
-DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
+DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native"
-inherit meson pkgconfig gtk-doc gobject-introspection vala
+inherit meson pkgconfig gtk-doc gobject-introspection vala useradd
-SRC_URI = " \
- https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PV}/geoclue-${PV}.tar \
+SRCREV = "8a24f60969d4c235d9918796c38a6a9c42e10131"
+SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;branch=master \
+ file://0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch \
"
-SRC_URI[md5sum] = "6228301ed62b587ebaa0438b97ce66e4"
-SRC_URI[sha256sum] = "3caa5e10190a34c17a9b3a9d1d8a19797ed197f07f36f6e35ce533a379efe155"
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_INCDIR
-export STAGING_LIBDIR
+S = "${WORKDIR}/git"
# Without this line, package is declared a library and named libgeoclue*
AUTO_LIBNAME_PKGS = ""
-PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
+PACKAGECONFIG ??= "3g modem-gps cdma nmea lib agent"
PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon"
-PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
+PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false"
+PACKAGECONFIG[agent] = "-Ddemo-agent=true,-Ddemo-agent=false,libnotify"
GTKDOC_MESON_OPTION = "gtk-doc"
EXTRA_OEMESON += " \
-Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
- -Ddemo-agent=false \
"
-FILES_${PN} += " \
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
+
+do_install:append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then
+ # Fix up permissions on polkit rules.d to work with rpm4 constraints
+ chmod 700 ${D}/${datadir}/polkit-1/rules.d
+ chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
+ fi
+}
+
+FILES:${PN} += " \
${datadir}/dbus-1/system-services \
+ ${datadir}/polkit-1/rules.d \
${libdir} \
${systemd_unitdir} \
${prefix}/libexec \
"
-FILES_${PN}-dev += " \
+FILES:${PN}-dev += " \
${datadir}/dbus-1/interfaces \
${datadir}/gir-1.0 \
"