aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/bpftool/bpftool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/bpftool/bpftool.bb')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb33
1 files changed, 25 insertions, 8 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index dd7eaa2aa63..8bddde94514 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -1,20 +1,33 @@
SUMMARY = "Inspect and manipulate eBPF programs and maps"
DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
of eBPF programs and maps."
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = "binutils elfutils"
+LICENSE = "GPL-2.0-only"
+DEPENDS = "binutils elfutils elfutils-native"
PROVIDES = "virtual/bpftool"
inherit bash-completion kernelsrc kernel-arch
-do_populate_lic[depends] += "virtual/kernel:do_patch"
+do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
-EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+EXTRA_OEMAKE = "\
+ V=1 \
+ -C ${S}/tools/bpf/bpftool \
+ O=${B} \
+ CROSS=${TARGET_PREFIX} \
+ CC="${CC} ${DEBUG_PREFIX_MAP} -fdebug-prefix-map=${STAGING_KERNEL_DIR}=${KERNEL_SRC_PATH}" \
+ HOSTCC="${BUILD_CC} ${BUILD_CFLAGS}" \
+ LD="${LD}" \
+ AR=${AR} \
+ ARCH=${ARCH} \
+ bash_compdir=${prefix}/share/bash-completion \
+"
+
+SECURITY_CFLAGS = ""
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST = "(x86_64|aarch64|riscv64).*-linux"
+COMPATIBLE_HOST:libc-musl = 'null'
do_compile() {
oe_runmake
@@ -26,8 +39,12 @@ do_install() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
-python do_package_prepend() {
- d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
+python do_package:prepend() {
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
}
B = "${WORKDIR}/${BPN}-${PV}"
+
+FILES:${PN} += "${exec_prefix}/sbin/*"
+
+BBCLASSEXTEND = "native nativesdk"