aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb')
-rw-r--r--meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
new file mode 100644
index 0000000000..ec0b4da935
--- /dev/null
+++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "C++11 port of docopt command-line interface description language and parser"
+
+DESCRIPTION = "docopt is library that lets you define a command line interface with the \
+utility argument syntax that has been used by command line utilities for \
+decades (formalized in POSIX.1-2017). From the description, docopt \
+automatically generates a parser for the command line arguments."
+
+HOMEPAGE = "https://github.com/docopt/docopt.cpp"
+
+LICENSE = "MIT | BSL-1.0"
+LIC_FILES_CHKSUM = "\
+ file://LICENSE-Boost-1.0;md5=e4224ccaecb14d942c71d31bef20d78c \
+ file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \
+"
+
+SRCREV = "42ebcec9dc2c99a1b3a4542787572045763ad196"
+PV = "0.6.3+git"
+
+SRC_URI = "\
+ git://github.com/docopt/docopt.cpp.git;protocol=https;branch=master \
+"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[boost] = "-DUSE_BOOST_REGEX=ON,-DUSE_BOOST_REGEX=OFF,boost"
+
+BBCLASSEXTEND = "native nativesdk"