aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/sip/sip_6.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/sip/sip_6.8.3.bb')
-rw-r--r--meta-oe/recipes-devtools/sip/sip_6.8.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/sip/sip_6.8.3.bb b/meta-oe/recipes-devtools/sip/sip_6.8.3.bb
new file mode 100644
index 0000000000..d12130af43
--- /dev/null
+++ b/meta-oe/recipes-devtools/sip/sip_6.8.3.bb
@@ -0,0 +1,24 @@
+# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "A Python bindings generator for C/C++ libraries"
+
+HOMEPAGE = "https://www.riverbankcomputing.com/software/sip/"
+LICENSE = "GPL-2.0-or-later"
+SECTION = "devel"
+LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
+
+inherit pypi setuptools3 python3native
+
+PYPI_PACKAGE = "sip"
+SRC_URI[sha256sum] = "888547b018bb24c36aded519e93d3e513d4c6aa0ba55b7cc1affbd45cf10762c"
+
+RDEPENDS:${PN} = " \
+ python3-core \
+ python3-packaging \
+ python3-logging \
+ python3-tomllib \
+ python3-setuptools \
+"
+
+BBCLASSEXTEND = "native"