aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/ltrace/ltrace_git.bb')
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace_git.bb22
1 files changed, 17 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
index f4033f7c27..63971970cf 100644
--- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
+++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -6,16 +6,15 @@ It can also intercept and print the system calls executed by the program.\
"
HOMEPAGE = "http://ltrace.org/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
PE = "1"
-PV = "7.91+git${SRCPV}"
+PV = "7.91+git"
SRCREV = "c22d359433b333937ee3d803450dc41998115685"
DEPENDS = "elfutils"
-RDEPENDS_${PN} = "elfutils"
-SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http \
+SRC_URI = "git://github.com/sparkleholic/ltrace.git;protocol=https;branch=master \
file://configure-allow-to-disable-selinux-support.patch \
file://0001-replace-readdir_r-with-readdir.patch \
file://0001-Use-correct-enum-type.patch \
@@ -25,7 +24,17 @@ SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http
file://0001-Add-support-for-mips64-n32-n64.patch \
file://0001-configure-Recognise-linux-musl-as-a-host-OS.patch \
file://0001-mips-plt.c-Delete-include-error.h.patch \
+ file://0001-move-fprintf-into-same-block-where-modname-and-symna.patch \
+ file://0001-hook-Do-not-append-int-to-std-string.patch \
+ file://0001-Bug-fix-for-data-type-length-judgment.patch \
+ file://0001-ensure-the-struct-pointers-are-null-initilized.patch \
+ file://0001-ppc-Remove-unused-host_powerpc64-function.patch \
+ file://0001-mips-Use-hardcodes-values-for-ABI-syscall-bases.patch \
+ file://0001-ppc-plt-do-not-free-symbol-libsym.patch \
+ file://0001-Fix-type-of-single-bit-bitfields.patch \
"
+SRC_URI:append:libc-musl = " file://add_ppc64le.patch"
+
S = "${WORKDIR}/git"
inherit autotools
@@ -34,6 +43,9 @@ PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
-do_configure_prepend () {
+COMPATIBLE_HOST:riscv64 = "null"
+COMPATIBLE_HOST:riscv32 = "null"
+
+do_configure:prepend () {
( cd ${S}; ./autogen.sh )
}