aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb')
-rw-r--r--meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb25
1 files changed, 14 insertions, 11 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
index 9af1e3f149..4cad7dce11 100644
--- a/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
+++ b/meta-oe/recipes-core/toybox/toybox-inittab_0.8.2.bb
@@ -1,20 +1,25 @@
SUMMARY = "Toybox Inittab Configuration"
-LICENSE = "BSD-0-Clause"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-0-Clause;md5=81eeb0083e31f11ab1e33ded846d521c"
+LICENSE = "0BSD"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/0BSD;md5=f667a3c3830a55a17ec3067709f4526c"
+# Unpack to ${S}/orig
+#
SRC_URI = "\
- file://inittab \
- file://rcK \
- file://rcS \
+ file://inittab;subdir=${BP}/orig \
+ file://rcK;subdir=${BP}/orig \
+ file://rcS;subdir=${BP}/orig \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-RCONFLICTS_${PN} = "\
+RCONFLICTS:${PN} = "\
busybox-inittab \
sysvinit-inittab \
"
+# Just being sure.
+B = "${S}"
+
# most users may want to have getty enabled by default
PACKAGECONFIG ??= "getty"
@@ -26,12 +31,10 @@ do_patch[noexec] = "1"
do_configure() {
# copy over files now to have a fresh start on each config
- for f in inittab rcK rcS; do
- cp ${WORKDIR}/$f ${S}
- done
+ cp orig/* .
for config in ${PACKAGECONFIG_CONFARGS}; do
- if [[ ${config} == "enable_getty" ]]; then
+ if [ "${config}" = "enable_getty" ]; then
echo "# generated by bitbake recipe ${PN}" >> ${S}/inittab
for console in "${SERIAL_CONSOLES}"; do
param=$(echo ${console} | sed s/\;/\ /g)
@@ -53,7 +56,7 @@ do_install() {
install -D -m 0744 ${S}/rcS ${D}${sysconfdir}/init.d/rcS
}
-FILES_${PN} = "\
+FILES:${PN} = "\
${sysconfdir}/inittab \
${sysconfdir}/init.d/rcK \
${sysconfdir}/init.d/rcS \