aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/ndctl/ndctl_v65.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/ndctl/ndctl_v65.bb')
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v65.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v65.bb b/meta-oe/recipes-core/ndctl/ndctl_v65.bb
new file mode 100644
index 0000000000..69ee1d476b
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl_v65.bb
@@ -0,0 +1,32 @@
+SUMMARY = "libnvdimm utility library"
+DESCRIPTION = "Utility library for managing the libnvdimm \
+(non-volatile memory device) sub-system in the Linux kernel. \
+The LIBNVDIMM subsystem provides support for three types of \
+NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
+simultaneously support both PMEM and BLK mode access."
+HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
+
+inherit autotools-brokensep pkgconfig bash-completion systemd
+
+SRCREV = "ed17fd14608d8de072c8c090ffc5fcf78c4f48ff"
+SRC_URI = "git://github.com/pmem/ndctl.git"
+
+DEPENDS = "kmod udev json-c keyutils"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
+PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
+
+do_configure_prepend() {
+ ${S}/autogen.sh
+}
+
+SYSTEMD_SERVICE_${PN} = "ndctl-monitor.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+FILES_${PN} += "${datadir}/daxctl/daxctl.conf"