aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb')
-rw-r--r--meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb38
1 files changed, 21 insertions, 17 deletions
diff --git a/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb b/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
index b89fe6771c..03076cbc60 100644
--- a/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
+++ b/meta-oe/recipes-bsp/edac-utils/edac-utils_git.bb
@@ -1,17 +1,21 @@
SUMMARY = "Userspace helper for Linux kernel EDAC drivers"
HOMEPAGE = "https://github.com/grondo/edac-utils"
+DESCRIPTION = "EDAC (Error Detection and Correction) is a set of Linux kernel \
+modules that handle reporting of hardware-related errors. Currently \
+these modules mainly handle detection of ECC memory errors for many \
+x86 and x86-64 chipsets and PCI bus parity errors."
SECTION = "Applications/System"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = " sysfsutils"
-SRCREV = "f9aa96205f610de39a79ff43c7478b7ef02e3138"
-PV = "0.18+git${SRCPV}"
+SRCREV = "1c57818ecee186aa47af0342149577df5302c022"
+PV = "0.18+git"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/grondo/edac-utils \
+SRC_URI = "git://github.com/grondo/edac-utils;branch=master;protocol=https \
file://make-init-script-be-able-to-automatically-load-EDAC-.patch \
file://add-restart-to-initscript.patch \
file://edac.service \
@@ -19,19 +23,19 @@ SRC_URI = "git://github.com/grondo/edac-utils \
inherit autotools-brokensep systemd
-do_configure_prepend () {
+do_configure:prepend () {
touch ${S}/ChangeLog
${S}/bootstrap
}
-RDEPENDS_${PN}_x86 = "dmidecode"
-RDEPENDS_${PN}_x86-64 = "dmidecode"
-RDEPENDS_${PN}_arm = "dmidecode"
-RDEPENDS_${PN}_aarch64 = "dmidecode"
-RDEPENDS_${PN}_powerpc = "dmidecode"
-RDEPENDS_${PN}_powerpc64 = "dmidecode"
-RDEPENDS_${PN}_powerpc64le = "dmidecode"
-RDEPENDS_${PN}_append = " \
+RDEPENDS:${PN}:x86 = "dmidecode"
+RDEPENDS:${PN}:x86-64 = "dmidecode"
+RDEPENDS:${PN}:arm = "dmidecode"
+RDEPENDS:${PN}:aarch64 = "dmidecode"
+RDEPENDS:${PN}:powerpc = "dmidecode"
+RDEPENDS:${PN}:powerpc64 = "dmidecode"
+RDEPENDS:${PN}:powerpc64le = "dmidecode"
+RDEPENDS:${PN}:append = " \
perl \
perl-module-file-basename \
perl-module-file-find \
@@ -42,11 +46,11 @@ RDEPENDS_${PN}_append = " \
perl-module-file-glob \
"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/edac.service ${D}/${systemd_unitdir}/system
sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}/${systemd_unitdir}/system/edac.service
}
-SYSTEMD_SERVICE_${PN} = "edac.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "edac.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"