aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/arptables/arptables_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/arptables/arptables_git.bb')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_git.bb16
1 files changed, 7 insertions, 9 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_git.bb b/meta-networking/recipes-support/arptables/arptables_git.bb
index cec1d1f77e..949794bf30 100644
--- a/meta-networking/recipes-support/arptables/arptables_git.bb
+++ b/meta-networking/recipes-support/arptables/arptables_git.bb
@@ -1,23 +1,21 @@
SUMMARY = "Administration tool for arp packet filtering"
SECTION = "net"
-LICENSE = "GPL-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-SRCREV = "f4ab8f63f11a72f14687a6646d04ae1bae3fa45f"
-PV = "0.0.4+git${SRCPV}"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
+SRCREV = "efae8949e31f8b2eb6290f377a28384cecaf105a"
+PV = "0.0.5+git"
SRC_URI = " \
- git://git.netfilter.org/arptables \
+ git://git.netfilter.org/arptables;branch=master \
file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \
- file://arptables-init-busybox.patch \
file://arptables-arpt-get-target-fix.patch \
- file://arptables-remove-bashism.patch \
file://arptables.service \
"
SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} = "arptables.service"
+SYSTEMD_SERVICE:${PN} = "arptables.service"
inherit systemd
@@ -31,7 +29,7 @@ do_install() {
fi
}
-RDEPENDS_${PN} += "perl"
+RDEPENDS:${PN} += "perl"
# the install target is not multi-job safe, but it doesn't do much
# so we just install serially