aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index d5e7341a01..d89ee1a206 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -42,10 +42,10 @@ inherit update-rc.d systemd
python __anonymous () {
import re
- karch = d.getVar('KARCH')
+ karch = d.getVar('TARGET_ARCH')
multilib = d.getVar('MLPREFIX')
- if multilib and karch == 'powerpc64':
+ if multilib and ( karch == 'powerpc64' or karch == 'arm' ):
searchstr = "lib.?32"
reg = re.compile(searchstr)
if reg.search(multilib):